NHS Claims
Incident Report for Dentally
Resolved
This incident has been resolved.
Posted Jan 24, 2018 - 17:49 GMT
Monitoring
The NHS server appears to be back online. Queued claims have now been submitted.
Posted Jan 24, 2018 - 16:52 GMT
Identified
The NHS server appears to be offline at the moment which is causing claims to be queued in Dentally. We're currently waiting on further updates from the NHS and will share information here when it's made available to us.

As soon as the NHS server is back online the backlog of claims will automatically be resubmitted for you.
Posted Jan 24, 2018 - 16:09 GMT