Slow Response Times
Incident Report for Dentally
Resolved
Response times have returned to normal however we will continue to monitor this.
Posted Oct 02, 2018 - 13:09 BST
Investigating
We're currently investigating reports of slow response times with Dentally
Posted Oct 02, 2018 - 11:48 BST
This incident affected: Dentally Application and API.