NHS Northern Ireland Claims Error

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 16:21 GMT

Monitoring

HSC have confirmed an outage which is now resolved. We will continue to monitor NHS Northern Ireland claims.
Posted Nov 13, 2025 - 09:36 GMT

Investigating

We identified an issue affecting a small number of NHS Northern Ireland claims returning in an errored state. We have reached out to the HSC and are currently investigating the issue.
Posted Nov 12, 2025 - 14:37 GMT
This incident affected: NHS Integration.