Pearl AI not loading images taken today

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 17:06 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2025 - 16:01 BST

Investigating

We are aware of an issue impacting Pearl AI, whereby some practices may be unable to see images taken today, and they will load up either a black screen or without the current images showing. Historical images are unaffected. Our engineers are investigating and working to restore full functionality.
Posted Aug 20, 2025 - 13:17 BST
This incident affected: Dentally Vision.