Global Microsoft Outages
Incident Report for Dentally
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 14:28 BST
Monitoring
We are aware of a global problem facing Microsoft Windows users resulting in their machines becoming unusable. We would like to reassure all users that no Dentally application services are affected by this issue and all are operating as normal.

Due to the increased demand on our support team as a result of this issue, there may be a delay in response until it is resolved.
Posted Jul 19, 2024 - 09:02 BST
This incident affected: Dentally Application.