Incorrect patients appearing in the Recently Viewed Patients list

Incident Report for Dentally

Monitoring

We have deployed a fix that will clear your recently viewed patients list and will behave as expected
Posted Jul 15, 2026 - 11:34 BST

Identified

The Recently Viewed Patients list is displaying incorrectly. This is a visual bug. We have found the cause and are working on a fix.

There is no data exposure issue, these are patients being viewed within the same practice.
Posted Jul 15, 2026 - 10:31 BST
This incident affects: Dentally Application.