Issues with NHS NI Claims

Incident Report for Dentally

Identified

HSCNI has identified the issue on their side and are reviewing it urgently. We will update the status as soon as more information becomes available to us.
Posted Apr 25, 2025 - 11:48 BST

Update

The issue has been referred to HSC NI, and we are awaiting their update.
Posted Apr 24, 2025 - 17:39 BST

Investigating

We are aware of an issue affecting NHS NI Claims and are currently investigating it.
Posted Apr 24, 2025 - 16:46 BST
This incident affects: NHS Integration.