Duplicate Recurring Appointments
Incident Report for Dentally
Resolved
This incident has been resolved.
Posted Nov 23, 2022 - 11:20 GMT
Identified
We've identified an issue where duplicate recurring appointments may be showing for some customers on the calendar. We're currently working on a fix and will post further details shortly.
Posted Nov 23, 2022 - 10:21 GMT
This incident affected: Dentally Application and API.