Stripe rate limit exceeded

Incident Report for Dentally

Resolved

This issue has now been resolved by Stripe
Posted Sep 19, 2025 - 12:35 BST

Monitoring

An issue has been identified with Stripe - Users are experiencing issues while accessing various interfaces. This is manifesting as a limit on Stripe API requests. Stripe are aware and investigating.

More info can be found at https://status.stripe.com
Posted Sep 19, 2025 - 11:35 BST
This incident affected: Dentally Application.