Slow response times
Incident Report for Dentally
Resolved
Response times have returned to normal levels.
Posted Nov 06, 2017 - 17:46 GMT
Identified
Response times are improving but Dentally will be slower to use than normal. We're working hard to get everything back to normal speed and will keep this page updated.
Posted Nov 06, 2017 - 17:16 GMT
Investigating
We're investigating slow response times in Dentally.
Posted Nov 06, 2017 - 16:41 GMT