Claim payment lines not automatically showing in account window
Incident Report for Dentally
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 10:41 GMT
Identified
The issue has been identified and we are working on a fix.
Please refresh your Dentally webpage if the claim payment line doesn't show, and it will then appear.
Posted Nov 14, 2024 - 03:23 GMT
Investigating
We are currently investigating this issue.
Please refresh your Dentally webpage if the claim payment line doesn't show, and it will then appear.
Posted Nov 14, 2024 - 01:44 GMT
This incident affected: Dentally Application.