Issue with Canadian insurance claims

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 15:24 BST

Investigating

We are investigating an issue affecting insurance claims in Canada, where incorrect details may be shown on a claim.
Posted Apr 21, 2026 - 14:40 BST
This incident affected: Claiming Services.