Electronic Payment Issues
Incident Report for Dentally
Resolved
This issue has now been resolved
Posted May 24, 2023 - 06:10 BST
Monitoring
A fix has now been applied to resolve the intermittent payments issue. Our engineering teams will continue to monitor the situation.
Posted May 24, 2023 - 05:01 BST
Identified
Our engineering teams have identified the issue and will shortly be deploying a fix. Please note all payments are still being processed.
Posted May 24, 2023 - 04:22 BST
Investigating
We are currently investigating an intermittent issue with electronic payments affecting Australian practices.
Posted May 24, 2023 - 04:10 BST
This incident affected: Dentally Application.