Intermittent NHS Submission Issues

Incident Report for Dentally

Resolved

The intermittent connection issue appears to have been resolved and we are now seeing claims successfully submitted once again. All failed submissions will be automatically resent.
Posted Nov 28, 2024 - 16:28 GMT

Investigating

We are investigating reports of intermittent failures when submitting NHS Claims.
Posted Nov 28, 2024 - 15:57 GMT
This incident affected: NHS Integration.