Dentally Vision - Degraded Service
Incident Report for Dentally
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 19:05 GMT
Identified
Our Engineering teams have identified a solution to slowness issues affecting a subset of our Dentally Vision users. This change will be applied outside of UK business hours to minimise service interruption.
Posted Mar 19, 2024 - 14:47 GMT
Investigating
We are currently investigating reports of slowness using Dentally Vision from a subset of users.
Posted Mar 19, 2024 - 12:32 GMT
This incident affected: Dentally Vision.