NHS Claims Submission Issues

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 13:08 GMT

Investigating

We are investigating reports of failures when submitting NHS Claims. We have notified the NHS service provider about this problem.
Posted Feb 04, 2025 - 13:04 GMT
This incident affected: NHS Integration.