Error cancelling Hicaps claims

Incident Report for Dentally

Resolved

This is now resolved
Posted Jun 13, 2025 - 02:44 BST

Monitoring

A fix has been implemented and we are monitoring the outcome
Posted Jun 13, 2025 - 02:02 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 13, 2025 - 01:23 BST

Update

We are continuing to investigate this issue.
Posted Jun 13, 2025 - 00:55 BST

Investigating

We are currently investigating this issue
You may see the error 'there was an error talking to connect' when trying to cancel the claim
Posted Jun 13, 2025 - 00:54 BST
This incident affected: Dentally Application.