Issue with payments via integrated payment terminals.

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 12:12 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2026 - 10:50 BST

Investigating

We are investigating an issue with payments via integrated payment terminals.
Posted Aug 18, 2026 - 10:06 BST
This incident affected: Dentally Application.