Issues affecting CA insurance claims

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 22:32 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2026 - 21:52 BST

Identified

We have identified the issue with Canadian claims and a fix is being implemented. Some claims are being processed successfully.
Posted Sep 21, 2026 - 21:11 BST

Investigating

We are investigating an issue affecting Canadian insurance claims.
Posted Sep 21, 2026 - 15:48 BST
This incident affected: Claiming Services.