Some users experiencing issues when deleting appointments

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 13:45 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 13:00 BST

Investigating

We’ve identified an issue affecting some users when attempting to deleting appointments in Dentally. Our team is currently investigating and working to resolve this as quickly as possible.
Posted Oct 08, 2025 - 12:44 BST
This incident affected: Dentally Application.