Database maintenance

Scheduled for Jun 6, 22:00 - 23:00 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 05, 2026 - 15:03 BST

Scheduled

We have some scheduled maintenance taking place on Saturday 6th June 2026. During this time, there may be a short period where you are unable to access Dentally, anticipated between 10pm-11pm BST.
The system will be fully operational again as soon as maintenance is complete.
Posted Jun 05, 2026 - 14:55 BST
This scheduled maintenance affects: Dentally Application.