Intermittent issues submitting CA insurance claims

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted May 27, 2026 - 20:10 BST

Monitoring

A fix has been implemented and we are monitoring.
Posted May 27, 2026 - 19:45 BST

Investigating

We are currently experiencing intermittent issues submitting CA insurance claims. We are working to resolve the issue.
Posted May 27, 2026 - 19:27 BST
This incident affected: Claiming Services.