HSC claims - Northern Ireland

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 17:45 GMT

Monitoring

We are now seeing HSC claims in Northern Ireland being processed successfully. We are continuing to monitor for any further issues.
Posted Nov 20, 2025 - 12:35 GMT

Investigating

Issues are being seen with HSC claims in Northern Ireland. We have contacted HSC and are investigating the issue.
Posted Nov 20, 2025 - 11:45 GMT
This incident affected: Claiming Services.