System performance issues

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 17:40 GMT

Monitoring

System performance has returned to normal, we are monitoring for any issues.
Posted Mar 02, 2026 - 16:47 GMT

Investigating

Some users may be experiencing performance issues when using Dentally which we are investigating.
Posted Mar 02, 2026 - 15:56 GMT
This incident affected: Dentally Application.