Australian customer's HICAPS payments time out at some practices.

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 14:14 BST

Monitoring

We've deployed a fix for this HICAPs payment time out issue and will monitor.
Posted Oct 06, 2025 - 05:56 BST

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2025 - 03:41 BST

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2025 - 03:23 BST

Identified

We have identified the problem and are working on a solution. Practices can put payments through manually.
Posted Oct 06, 2025 - 03:22 BST
This incident affected: Claiming Services.