Canadian Insurance display issues

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 18:32 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 18:28 BST

Identified

We are aware of the issues with loading the insurance-related page in Dentally. We are addressing this urgently.
Posted Jun 03, 2025 - 17:46 BST
This incident affected: Claiming Services.