Issue with processing payments and claims through integrated terminals

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 13:05 BST

Identified

We’ve identified an issue causing timeouts and slowness when processing payments and claims through integrated terminals such as Worldpay, Dojo, and HICAPS.

Payment terminals can be used as normal, however the integration with Dentally may be affected.

Our team is investigating and working with Microsoft Azure to restore normal performance as quickly as possible. We apologise for the disruption and appreciate your patience.
Posted Oct 09, 2025 - 10:12 BST
This incident affected: Dentally Application.