Dentally Slowness

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted May 19, 2025 - 17:29 BST

Monitoring

Dentally is performing at normal levels again and we are monitoring performance to ensure that this issue is fully resolved.
Posted May 19, 2025 - 11:32 BST

Investigating

We are currently investigating reports of intermittent slowness
Posted May 19, 2025 - 10:51 BST
This incident affected: Dentally Application.