Slowness in Dentally Vision

Incident Report for Dentally

Resolved

The incident has been resolved and request times have returned to normal
Posted Jun 16, 2026 - 11:53 BST

Monitoring

A fix has been implemented and we are monitoring the results
Posted Jun 16, 2026 - 10:37 BST

Identified

We are seeing slowness for users using Dentally Vision following an update. A fix has been identified and is being actioned now
Posted Jun 16, 2026 - 10:09 BST
This incident affected: Dentally Vision.