Issues with NHS Wales Claims

Incident Report for Dentally

Resolved

This incident has been resolved. Practices should be able to charge treatments and submit claims in the usual way.
Posted Apr 01, 2025 - 10:23 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 10:20 BST

Identified

We are aware of an issue with populating price data for NHS Wales Claims. We are working on the fix.
Posted Apr 01, 2025 - 10:08 BST
This incident affected: Claiming Services.