NHS Claims not receiving responses
Incident Report for Dentally
Resolved
We have been informed by EDI Support that this issue is resolved and all claims are now up to date
Posted Jun 10, 2024 - 16:03 BST
Monitoring
We have received an update from EDISupport stating that all submitted claims have been processed, however the responses to confirm this have been delayed. It is anticipated that all responses will be sent once the problem is resolved.
Posted Jun 10, 2024 - 12:02 BST
Identified
We are aware the issue with processing claims still exists and are currently waiting on further updates from EDISupport. Once any timescales for resolution are provided, we will post here for awareness.
Posted Jun 10, 2024 - 09:15 BST
Investigating
We are aware that EDISupport are currently investigating an issue with practices receiving claims responses. We are awaiting an update from them. At this point in time, we do not know whether claims have not been received or passed for processing, only that responses are not being sent.
Posted Jun 07, 2024 - 10:28 BST
This incident affected: NHS Integration.