NHS Server Issues
Incident Report for Dentally
Resolved
The NHS have fixed their issue and all outstanding NHS claims have been successfully submitted.
Posted Oct 10, 2017 - 14:36 BST
Update
The NHS are still working to resolve their issues and are posting updates on their website https://www.nhsbsa.nhs.uk
Posted Oct 10, 2017 - 10:19 BST
Identified
The NHS server is currently offline so NHS claims will be queued until the NHS have rectified the issue. We'll update this page when we hear more.
Posted Oct 09, 2017 - 11:35 BST