Dentally to HICAPs terminal connection issues affecting AU practices
Incident Report for Dentally
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 07:46 BST
Update
We are continuing to monitor for any further issues.
Posted Apr 11, 2024 - 06:58 BST
Monitoring
Our engineering teams have implemented a fix for this issue and are currently monitoring.
Posted Apr 11, 2024 - 06:57 BST
Identified
Our engineering teams have identified the issue resulting in some AU practices being unable process HICAPS submissions. A fix is presently being put in place.
Posted Apr 11, 2024 - 06:45 BST
Update
Our engineering teams are continuing to investigate the cause of this issue.
Posted Apr 11, 2024 - 05:38 BST
Investigating
We are currently having several reports from customers that the connection between the Dentally app and local HICAPs terminals is not working. The team is looking into what could be causing this and how we can fix as quickly as possible.

Users will still be able to manually take claims on the terminal and enter them into the Dentally system through the 'Manual claim' process.
Posted Apr 11, 2024 - 00:31 BST
This incident affected: Claiming Services.