Support issues may be delayed

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 16:47 BST

Investigating

We’re currently experiencing an issue where all support chats are going directly to our support team rather than starting with Ellie, our AI agent. This means replies may be delayed, but we’ll be with you as soon as possible. Thank you so much for your patience!
Posted Apr 14, 2026 - 13:19 BST
This incident affected: Support.