All online Dentally Vision functionality unavailable

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 05:41 BST

Monitoring

We have returned full service to the Dentally Vision application. We are monitoring for any further issues.
Posted Jul 29, 2025 - 01:12 BST

Investigating

We are investigating the issue. Offline mode is still available, so images taken while Dentally Vision is down can be uploaded later once functionality is restored. More information about offline mode can be found here (https://help.dentally.com/en/articles/8523380-does-dentally-vision-work-offline).
Posted Jul 29, 2025 - 00:47 BST
This incident affected: Dentally Vision.