Dentally Degredation of Service
Incident Report for Dentally
Postmortem

On Wednesday 2nd February, our application hosting provider had a major incident with their services which led to Dentally being unresponsive and slow for some of our users.  

We apologise for this incident which impacted our system for fifteen minutes. Our provider identified the cause of the issue and this has subsequently been resolved. 

Dentally did not go offline during this time, but our ability to process demand meant that the software became unresponsive to some users.  We are performing an in-depth review to create additional safeguards to prevent this type of issue from occurring again.

Our team come to work every day to deliver cloud enabled software solutions to help make the lives of dental practitioners easier, we work tirelessly to support you in delivering exceptional patient care.   We understand that you will be disappointed but please be assured we are committed to ensuring that Dentally is responsive to all of our users at all times.

Posted Feb 08, 2022 - 15:32 GMT

Resolved
This incident has been resolved.
Posted Feb 02, 2022 - 17:12 GMT
Monitoring
Issue has been resolved but we are continuing to monitor all systems
Posted Feb 02, 2022 - 14:40 GMT
Identified
Our upstream hosting provider is having issues resulting is a degraded performance of Dentally. We are working with the provider to restore service.
Posted Feb 02, 2022 - 14:22 GMT
Investigating
We are currently investigating this issue.
Posted Feb 02, 2022 - 14:10 GMT
This incident affected: Dentally Application and API.