Dentally Portal - Issue with appointment booking
Incident Report for Dentally
Resolved
This issue has been resolved, online booking and payments are working as expected.
Posted Feb 13, 2024 - 15:02 GMT
Monitoring
We've been notified of an issue in online booking where a payment is taken from patient without booking being made. We've released a fix and are monitoring for any further problems.
Posted Feb 13, 2024 - 11:26 GMT
This incident affected: Dentally Portal.