Issue with Canada Claims
Incident Report for Dentally
Resolved
CDA and iTrans claims service have confirmed that issues have been resolved and services is operating as normal.
Posted Nov 12, 2024 - 14:44 GMT
Investigating
CDA/iTrans have made us aware of an issue with transmitting claims to all Instream carriers. Their technicians are investigating the source of the issue and will keep posted on the updates.
Posted Nov 12, 2024 - 14:10 GMT
This incident affected: Claiming Services.