Dentally Portal - Issue with practice specific links
Incident Report for Dentally
Resolved
This issue has been resolved.
Posted Jul 07, 2023 - 11:28 BST
Identified
We have been notified of an issue with practice specific links not working for some of our Dentally Portal practices. Our engineering team have identified the issue and are currently working through a resolution to the problem.
Posted Jul 07, 2023 - 10:57 BST
This incident affected: Dentally Portal.