Intermittent Blank Screen - Patient Details
Incident Report for Dentally
Resolved
This issue has now been resolved.
Posted May 13, 2022 - 15:56 BST
Investigating
We are currently investigating an intermittent issue resulting in a blank screen for some users when loading patient details.
Posted May 13, 2022 - 15:46 BST
This incident affected: Dentally Application.