Issues submitting claims - Northern Ireland Practices

Incident Report for Dentally

Resolved

We have received confirmation that the issue has been resolved and submissions are now working as expected
Posted Jul 02, 2025 - 09:16 BST

Identified

We have received an update from HSCNI. They are working to resolve the issue urgently
Posted Jul 02, 2025 - 09:08 BST

Investigating

We have been made aware of an issue preventing claims being submitted by practices based in Northern Ireland.
Posted Jul 02, 2025 - 09:05 BST
This incident affected: Claiming Services.