NHS Claims Responses.
Incident Report for Dentally
Resolved
We have been informed by our NHS partners that this problem is now resolved.
Posted Mar 21, 2024 - 17:42 GMT
Identified
We have received an update that this problem has been escalated and is being investigated by the NHS Service supplier. We are continuing to press for a resolution to this issue.
Posted Mar 21, 2024 - 10:25 GMT
Update
We are continuing to work with our NHS partners to determine the cause of this issue. We will share the results of their investigation as soon as we have them.
Posted Mar 20, 2024 - 17:32 GMT
Investigating
We are currently investigating an issue where daily scheduled responses are not being received by Dentally. We are in touch with the NHS and will have more information shortly.
Posted Mar 20, 2024 - 15:30 GMT
This incident affected: NHS Integration.