Loading issues affecting claim management for some Canadian practices

Incident Report for Dentally

Resolved

This incident had been resolved.
Posted Sep 02, 2026 - 21:07 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 20:34 BST

Investigating

We are investigating loading issues affecting claim management for some Canadian practices.
Posted Sep 02, 2026 - 19:53 BST
This incident affected: Claiming Services.