NHS Claims
Incident Report for Dentally
Resolved
This incident has been resolved and the queued NHS claims have been processed.
Posted Dec 04, 2019 - 23:49 GMT
Update
We're still waiting for the NHS to resolve their issue. We will post further updates as we receive them from the NHS.
Posted Dec 04, 2019 - 15:34 GMT
Identified
The NHS in England and Wales are currently having problems with their server and as a result are unable to accept claims. Any claims sent from Dentally will he held and processed once the NHS's server is back online.
Posted Dec 04, 2019 - 10:43 GMT
This incident affected: NHS Integration.