Dentally Slowness

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted May 08, 2025 - 07:28 BST

Monitoring

The root cause has been identified and a change instigated to restore performance. Our team are monitoring the situation closely.
Posted May 07, 2025 - 13:00 BST

Investigating

We are currently investigating reports of slowness within the application while uploading and viewing documents.
Posted May 07, 2025 - 11:09 BST
This incident affected: Dentally Application.