APAC Dentally - performance issues

Incident Report for Dentally

Resolved

We have identified and fixed the issue that was causing slow load times for Dentally. All customers should now be able to access services normally. Thank you for your patience while we worked to restore full performance.
Posted Feb 11, 2026 - 06:15 GMT

Monitoring

We have identified and deployed a fix to issues affecting APAC customers access to Dentally. We'll monitor and update all customers thorugh our status page.
Posted Feb 11, 2026 - 02:45 GMT

Investigating

We are aware of an issue currently affecting the load times within Dentally, please keep an eye on on this page as we work to resolve this as quickly as possible.
Posted Feb 11, 2026 - 00:41 GMT
This incident affected: Dentally Application.