Issues submitting claims - Northern Ireland Practices

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 16:58 BST

Identified

We have received an update from HSCNI. They are working to resolve the issue urgently. Northern Ireland based practices continue to have issues preventing the submission of claims. The previous incident was closed in error.
Posted Jul 02, 2025 - 09:21 BST
This incident affected: Claiming Services.