Worldpay issues

Incident Report for Dentally

Resolved

Worldpay Integration
Microsoft has confirmed the issue has been resolved
Posted Jan 26, 2026 - 11:47 GMT

Update

We are continuing to work on a fix for this issue.
Posted Jan 26, 2026 - 09:18 GMT

Identified

We are aware of issues with Worldpay causing delays and connectivity issues for practices using the World pay card terminal integration. Please be aware Worldpay are aware and are working on a fix to resolve this issue.
Posted Jan 26, 2026 - 09:18 GMT
This incident affected: Dentally Application.