The issue affecting email delivery has been resolved. Normal operation has been restored, and we appreciate your patience whilst we worked our email providers to resolve this.
Posted Dec 03, 2024 - 13:25 GMT
Update
The issue affecting email delivery to @btinternet.com, @btopenworld.com, and @talk21.com remains under their investigation. We appreciate your patience as our team work towards a resolution and we will provide more information as soon as it becomes available.
Posted Nov 28, 2024 - 09:40 GMT
Update
We are continuing to investigate the email delivery issues, there are no further updates at this time, but we remain actively engaged in resolving the problem.
Posted Nov 26, 2024 - 15:27 GMT
Update
We are still seeing some email delivery issues affecting the @btinternet.com, @btopenworld.com & @talk21.com domains. We have reported this problem and are continuing to investigate.
Posted Nov 26, 2024 - 08:25 GMT
Identified
We have identified a delivery issue with the below email domains and are currently working with BT to resolve the problem: - @btinternet.com - @btopenworld.com - @talk21.com
Posted Nov 25, 2024 - 11:04 GMT
Investigating
We are aware of intermittent email delivery issues and are currently investigating