Context menu scroll issue

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 10:53 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 09, 2026 - 09:56 BST

Investigating

We’re aware of the issue affecting some users with selecting templates using the right-click menu. This is being actively investigating, and we’ll provide an update as soon as possible.
Posted Sep 09, 2026 - 09:39 BST
This incident affected: Dentally Application.